Investigating reports of processing delays
Incident Report for Smartling
Resolved
This incident has been resolved.
Posted over 1 year ago. Jul 12, 2017 - 10:59 EDT
Investigating
We are currently investigating reports of delays in content assignments processing
Posted over 1 year ago. Jul 12, 2017 - 08:50 EDT