Investigating reports of errors on Jobs Details page
Incident Report for Smartling
Resolved
This incident has been resolved.
Posted May 22, 2020 - 13:46 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 22, 2020 - 13:45 EDT
Investigating
We are currently investigating reports of errors on Jobs details page
Posted May 22, 2020 - 13:41 EDT