DeepL MT Profile Processing Delays

Incident Report for Smartling

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 12:01 EDT

Identified

Some DeepL MT Profiles may experience processing delays.Some DeepL MT Profiles may experience processing delays. Our engineering team is working to resolve the issue.
Posted Jun 25, 2026 - 10:13 EDT