Investigating issue related to agency logins
Incident Report for Smartling
Resolved
This incident has been resolved.
Posted Oct 05, 2020 - 23:06 EDT
Identified
We have confirmed that some agency users may not be able to log in to the platform. We are currently implementing a fix.
Posted Oct 05, 2020 - 19:25 EDT