We are currently investigating reports of dashboard performance issues
Incident Report for Smartling
Resolved
This incident has been resolved.
Posted 8 months ago. Apr 09, 2017 - 02:14 EDT
Monitoring
Smartling engineers have restored normal service and continue to monitor situation
Posted 8 months ago. Apr 09, 2017 - 02:06 EDT
Investigating
We are currently investigating this issue.
Posted 8 months ago. Apr 09, 2017 - 01:26 EDT