Reports of errors with Translation Interface (GDN is not affected)
Incident Report for Smartling
Resolved
The issue has been resolved and all systems are 100% operational.
Posted 9 months ago. Mar 01, 2017 - 05:45 EST
Investigating
We are currently investigating reports of error message with Translation Interface
Posted 9 months ago. Mar 01, 2017 - 04:57 EST